Slow page load times

Incident Report for Swoogo

Resolved

This incident has been resolved.
Posted May 13, 2026 - 17:54 UTC

Monitoring

Our team continues to work on mitigation in parallel with our upstream provider's efforts. Performance and page load time has remained stable since our last update and we'll keep you updated here.
Posted May 13, 2026 - 16:23 UTC

Identified

We have identified the issue related to an upstream service provider and we are working with their support team. We are also implementing mitigations on our end to reduce the impact in the meantime.
Posted May 13, 2026 - 15:51 UTC

Investigating

We're investigating the source of slow page load times and errors being encountered by some of our users. We'll keep you posted here as we identify and resolve the issue.
Posted May 13, 2026 - 15:11 UTC