Platform Performance Degradation

Incident Report for Swoogo

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 00:30 UTC

Monitoring

Platform performance is now back to normal and we're continuing to monitor.
Posted Feb 26, 2026 - 00:10 UTC

Update

We're continuing to work on mitigations for customer facing errors on the platform.
Posted Feb 25, 2026 - 23:20 UTC

Identified

We've identified the source of the issue and working on mitigation.
Posted Feb 25, 2026 - 22:56 UTC

Investigating

We are currently investigating reports of slowness affecting the Swoogo platform.
Posted Feb 25, 2026 - 22:12 UTC
This incident affected: Event Registration and Webhooks.