Swoogo platform

Incident Report for Swoogo

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:59 UTC

Monitoring

We have implemented a few fixes today to mitigate the impact of the cloud provider outage. We will keep this status page incident in Monitoring state until our team confirms that any upstream cloud provider issues which could potentially impact us have been resolved.
Posted Oct 20, 2025 - 21:11 UTC

Update

Authentication issues are now resolved. We are continuing to mitigate any sluggishness in the platform caused by the upstream cloud provider outage.
Posted Oct 20, 2025 - 17:36 UTC

Update

We are also noticing intermittent sluggishness within the platform, related to the current internet wide outages.
Posted Oct 20, 2025 - 16:57 UTC

Identified

We have identified an issue with customer login and authentication related to the widespread internet issues affecting a major cloud provider today. Will keep customers posted here with updates as we mitigate the impact.
Posted Oct 20, 2025 - 16:39 UTC
This incident affected: Swoogo ID.